Requisitos del sistema para NetFlow Analyzer

    Los requisitos de hardware recomendados para instalar y ejecutar NetFlow Analyzer Professional & Enterprise Edition son los siguientes: 

    Parámetro Edición profesional Edición de Empresa
    Servidor central Coleccionista
    Procesador Procesador de cuatro núcleos a 2,4 GHz 2,4 GHz de doble núcleo 3,2 GHz de cuatro núcleos
    RAM 4 GB 4 GB 8 GB
    Espacio en disco duro 200GB para base de datos 600 GB Disco duro SATA de 1 TB
    Sistema operativo 64 bits 64 bits 64 bits

     

    Tenga en cuenta que el cambio en la tasa de flujo conducirá a cambios en los requisitos del sistema como se indica a continuación: 

    Tasa de flujo / segundo Procesador RAM Espacio en disco para datos agregados (para siempre) Espacio adicional en disco para RawData (opcional) Tipo de servidor

    0 a 3k

    Procesador de cuatro núcleos a 2,4 GHz 4 GB 200 GB 75 GB / día -

    3k a 6k

    Procesador de cuatro núcleos a 3,2 GHz 6 GB 200 GB 150GB / día 64 bits

    6k a 9k

    Procesador de cuatro núcleos a 3,2 GHz 8 GB 200 GB 225GB / día 64 bits

    9k a 10k

    Procesador de cuatro núcleos a 3,2 GHz 16 GB 200 GB 250GB / día 64 bits

    10k a 25k

    Procesador de cuatro núcleos a 3,2 GHz 18 GB 225 GB - 64 bits

    25.000 a 50.000

    Procesador de cuatro núcleos a 3,2 GHz 20 GB 250 GB - 64 bits

    50k a 75k

    Procesador de cuatro núcleos a 3,2 GHz 22 GB 300 GB - 64 bits

    75 k a 100 k

    Procesador de cuatro núcleos a 3,2 GHz 24 GB 350 GB - 64 bits

    100k (con datos brutos)

    Procesador de cuatro núcleos 2 x 3,2 GHz 48 GB + 350 GB 1,5 TB / día 64 bits

    * Los datos agregados se calculan sobre la base de los 100 registros principales.

     

    Para el dispositivo que exporta NetFlow, asegúrese de que el formato de la versión de exportación de NetFlow sea exactamente el mismo que el formato de la versión 5 o la versión 7 o la versión 9 de Cisco NetFlow. Para obtener información sobre los dispositivos Cisco y las versiones de IOS que admiten Netflow, consulte la  tabla de compatibilidad con dispositivos Cisco NetFlow  .

     

    Requisitos de Software

    Sistema operativo compatible Navegadores compatibles Base de datos compatible
    • Windows Server 2019
    • Windows Server 2016
    • Windows Server 2012 R1 y R2
    • Windows 10
    • Windows 8
    • Windows 7
    • Windows Vista
    • Windows 2008 - R1 y R2
    • RedHat Linux 6.0 y superior
    • Cent OS 6.0 y superior
    • Fedora 18 y superior
    • Debian versión 6.0 y superior
    • Ubuntu 12 y superior
    • SUSE 10 y superior
    • Google Chrome (preferido)
    • Mozilla Firefox
    • Microsoft Edge
    • IE11
    • PostgreSQL: incluido con el producto.
    • MSSQL: también disponible.
      Versiones compatibles: SQL 2019 | SQL 2017 | SQL 2016 | SQL 2014 | SQL 2012 | SQL 2008
    • Para el complemento HighPerf - PostgreSQL - Incluido con el producto.

     

    • Para producción, utilice versiones de SQL de 64 bits
    • El modo de recuperación debe establecerse en SIMPLE.
    • SQL y NetFlow deben estar en la misma LAN. Actualmente, las instalaciones de SQL basadas en WAN no son compatibles.

    Requisitos del puerto

    Nombre del puerto Números de puerto predeterminados Uso

    Puerto del servidor web 

    8060 Este es el puerto en el que se conectará al servidor NetFlow Analyzer desde un navegador web. Puede cambiar esto en cualquier momento desde la   pestaña Configuración .

     Puerto de escucha de NetFlow 

    9996 Este es el puerto de escucha en el que se reciben las exportaciones de NetFlow de los enrutadores. Puede cambiar esto en cualquier momento desde la  pestaña Configuración  .

     Puerto de base de datos integrado 

    13306 Este es el puerto predeterminado que se utiliza para conectarse a la base de datos PostgreSQL en NetFlow Analyzer.

     MSSQL 

    1433 Este es el puerto que conecta NetFlow Analyzer a una base de datos SQL.

     SNMP 

    161 Este es el puerto SNMP predeterminado para obtener la información del dispositivo y configurar NBAR basado en SNMP.

     Puerto de base de datos HighPerf 

    27839 Este es el puerto de base de datos de HighPerf predeterminado que conecta NetFlow Analyzer a la base de datos de HighPerf.

     Envoltura 

    32000-32999  

     JVM 

    31000-31999 Para conectarse a Wrapper.

     Puerto HTTPS 

    443 Este es el puerto a través del cual el recolector se comunica con el servidor central.

    Requisitos de la base de datos

    La siguiente tabla enumera los requisitos básicos para su servidor de base de datos OpManager.

    PostgreSQL

    • Viene incluido con el producto.
    • En caso de conmutación por error, utilice MS SQL.

    Microsoft SQL

    1. Versiones compatibles :

    SQL 2019 | SQL 2017 | SQL 2016 | SQL 2014 | SQL 2012 | SQL 2008

    2. Avisos importantes:

    1. Para producción, utilice versiones de SQL de 64 bits.
    2. El modo de recuperación debe establecerse en SIMPLE.
    3. SQL y OpManager deben estar en la misma LAN. Actualmente, las instalaciones de SQL basadas en WAN no son compatibles.

    3. Colación:

    • Inglés con configuración de clasificación (SQL_Latin1_General_CP1_CI_AS)
    • Noruego con configuración de intercalación (Danish_Norwegian_CI_AS)
    • Chino simplificado con configuración de clasificación (Chinese_PRC_CI_AS)

    • Japonés con configuración de clasificación (Japanese_CI_AS)
    • Alemán con configuración de intercalación (German_PhoneBook_CI_AS)

    4. Autenticación:

    Modo mixto (MSSQL y autenticación de Windows).

    5. BCP:

    " Bcp.exe " y " bcp.rll " deben estar disponibles en el directorio bin.

    La utilidad BCP proporcionada con Microsoft SQL Server es una utilidad de línea de comandos que le permite importar y exportar grandes cantidades de datos dentro y fuera de las bases de datos del servidor SQL rápidamente. El bcp.exe y bcp.rll estarán disponibles en el directorio de instalación de MSSQL. Si MSSQL está en una máquina remota, copie los archivos bcp.exe y bcp.rll y péguelos en el directorio <\ OpManager \ bin>.

    La versión del servidor SQL compatible con SQL Native Client debe instalarse en el mismo servidor.

    Requisitos previos del complemento HighPerf

    Sistemas operativos compatibles
    Ventanas Linux
    • Microsoft Windows Server 2019
    • Microsoft Windows Server 2016
    • Microsoft Windows Server 2012 R2
    • RHEL 7.x
    • CentOS 7.x
    • OL 7.x
    • SLES 12
    • Ubuntu 20 (APT)
    • Debian 10 (APT)

    Requisitos de hardware

    Tasa de flujo / segundo Procesador RAM Espacio adicional en disco para
    datos sin procesar (opcional)

    0 - 10k

    8 núcleos / 16 hilos o más.
    3,5 GHz o superior.

    24 GB

    100 GB / día

    10 - 25k

    8 núcleos / 16 hilos o más.
    3,5 GHz o superior.

    24 GB

    250 GB / día

    25k - 50k

    8 núcleos / 16 hilos o más.
    3,5 GHz o superior.

    24 GB o más

    500 GB / día

    50k - 75k

    16 núcleos / 32 hilos o más.
    3,5 GHz o superior.

    32 GB o más

    750 GB / día

    75.000 - 100.000

    16 núcleos / 32 hilos o más.
    3,5 GHz o superior.

    32 GB o más

    1000 GB / día

    Recomendaciones

    1. Se recomiendan CPU con una puntuación PassMark combinada total de 10,000 o más. Para obtener más información, haga clic aquí .
    2. Recomendación de disco duro:
      • Se recomienda HDD con RPM 10000 o superior. SSD es ideal para un mejor rendimiento.
      • La velocidad de lectura y escritura debe ser de 350MiB / so superior para hasta 50k flujos / seg.
      • La velocidad de lectura y escritura debe ser de 500MiB / so superior para flujos de 50k a 100k / seg.

    Nota:

    • Recomendamos encarecidamente asignar una máquina dedicada para NetFlow Analyzer.
    • El complemento HighPerf solo es compatible con la base de datos PostgreSQL.
    • Los datos agregados se calculan sobre la base de los 100 registros principales.
    • El caudal y el espacio en disco se calculan sobre la base de 1000 interfaces.
    • No recomendamos habilitar Attacks (ASAM) si la tasa de flujo es superior a 10k flujos / seg.

    Estas recomendaciones de memoria (RAM) se calculan para un máximo de 200 dispositivos (enrutadores) y variarán según la carga.

    Nota: NetFlow Analyzer se ejecuta tanto en Windows como en Linux, es compatible con las versiones 5/7/9 de NetFlow®, sFlow®, cflowd®, J-Flow®, IPFIX®, NetStream®. Para saber qué dispositivos admite, consulte la sección Configuración de dispositivos Cisco de la Guía del usuario .